ReIMG - logo relationship?

Need help with your forum? Ask away. Remember though that there's always http://www.phpbb.com/community

Moderator: Experts

Post Reply
Master_Cylinder
Posts: 13
Joined: Tue Aug 06, 2013 11:36 am

ReIMG - logo relationship?

Post by Master_Cylinder » Tue Feb 18, 2014 1:43 am

I'm trying to center my phpBB prosilver logo and the typical solutions aren't working so I'm wondering if it's related to ReIMG or maybe some other MOD.

This is what I read (several threads) and tried:

search:

Code: Select all

    #logo {
       float: left;
       width: auto;
       padding: 10px 13px 0 10px;
    }
replace with:

Code: Select all

    #logo {
       float: left;
       width: 100%;
       padding: 10px 13px 0 10px;
       text-align: center;
    }
search:

Code: Select all

    #site-description {
       float: left;
       width: 70%;
    }
replace with:

Code: Select all

    #site-description {
       float: left;
       width: 100%;
    }
For some reason the logo stays left but the site description is now under the logo. I'd like the site description justified left and the logo centered.

User avatar
DavidIQ
Site Admin
Posts: 581
Joined: Thu Sep 07, 2006 4:31 pm
Location: Earth
Contact:

Re: ReIMG - logo relationship?

Post by DavidIQ » Tue Feb 18, 2014 4:31 pm

This is the only style change ReIMG makes:

Code: Select all

<style type="text/css" media="screen, projection">
<!--
	.attachbox { width: 97%; }
	.attach-image
	{
		overflow: hidden;
		max-height: none;
	}
-->
</style>
That is specific to the topic posts so no it wouldn't affect the logo. Plus the onload attributes are only being added to images that are within posts so those would be the only ones that would be getting processed. I would try inspecting the area with either Chrome's or IE's developer tools to make sure your changes are indeed applying and if something else may need to be added.

Master_Cylinder
Posts: 13
Joined: Tue Aug 06, 2013 11:36 am

Re: ReIMG - logo relationship?

Post by Master_Cylinder » Tue Feb 18, 2014 5:25 pm

I looked with the chrome and IE tools but it's all greek to me. I can find the logo section but I don't see what needs to be changed or what might be conflicting. It was worth a try... ;)

User avatar
DavidIQ
Site Admin
Posts: 581
Joined: Thu Sep 07, 2006 4:31 pm
Location: Earth
Contact:

Re: ReIMG - logo relationship?

Post by DavidIQ » Tue Feb 18, 2014 8:29 pm

Link?

Master_Cylinder
Posts: 13
Joined: Tue Aug 06, 2013 11:36 am

Re: ReIMG - logo relationship?

Post by Master_Cylinder » Tue Feb 18, 2014 8:36 pm

DavidIQ wrote:Link?
I'd rather not post it publicly but you can see the email domain that I registered here with and add /forums to that. ;)

Master_Cylinder
Posts: 13
Joined: Tue Aug 06, 2013 11:36 am

Re: ReIMG - logo relationship?

Post by Master_Cylinder » Tue Feb 18, 2014 10:24 pm

I tried editing overall_header to replace:

Code: Select all

<div align="center" id="site-description">
with:

Code: Select all

<div style="text-align:center" id="site-description">
but that didn't help either...

Master_Cylinder
Posts: 13
Joined: Tue Aug 06, 2013 11:36 am

Re: ReIMG - logo relationship?

Post by Master_Cylinder » Thu Feb 20, 2014 2:31 pm

bump?

User avatar
DavidIQ
Site Admin
Posts: 581
Joined: Thu Sep 07, 2006 4:31 pm
Location: Earth
Contact:

Re: ReIMG - logo relationship?

Post by DavidIQ » Mon Feb 24, 2014 8:57 am

Take "float: left;" out from the #logo css definition.

Master_Cylinder
Posts: 13
Joined: Tue Aug 06, 2013 11:36 am

Re: ReIMG - logo relationship?

Post by Master_Cylinder » Wed Mar 12, 2014 6:53 am

Thanks for looking. That didn't work (yes, I purged the cache), here's the sections I have for logo and site-description...

Code: Select all

#logo {
	width: 100%;
	padding: 10px 13px 0 10px;
    text-align: center;
}

a#logo:hover {
	text-decoration: none;
}

Code: Select all

#site-description {
	float: left;
	width: 100%;
}
*shrug*


Perhaps something in overall_header?

Code: Select all

		<div class="headerbar">
			<div class="inner"><span class="corners-top"><span></span></span>

			<div style="text-align:center" id="site-description">
				<a href="<!-- IF U_SITE_HOME -->{U_SITE_HOME}<!-- ELSE -->{U_INDEX}<!-- ENDIF -->" title="<!-- IF U_SITE_HOME -->{L_SITE_HOME}<!-- ELSE -->{L_INDEX}<!-- ENDIF -->" id="logo">{SITE_LOGO_IMG}</a>
				<p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
			</div>
I even tried <center> tags around the <a href to </a> tags but that didn't work either. It looks like it *should* be centered but I can't figure out why it's not...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest